osCommerceCoders.com

Affordable end to end oscommerce solutions with
Search Engine Optimization

Email : osCommerceCoders@gmail.com
Call : +1 818-574-3596 (USA) / +44 (020) 8123-6463 (UK)

Archive for April, 2009

This happens due to a bug in OSCommerce after the server upgrade is from PHP 4.x to PHP 5. The way the code was written in upload.php was using an undocumented feature that was not officially supported, and subsequently did not carry over into PHP 5.

To fix this, edit the ‘upload.php’ file mentioned in the error message using a text editor. Open the file and find the line (about 30 lines down) that says:

// self destruct
$this = null;

And edit it to say this:

// self destruct
// $this = null;
unset($this);

(basically comment out with // the $this = null; line and add the unset($this); line)

Your admin panel should work properly now.

This is a common issue with a working admin panel when php version upgrade to 5 is done

For a flat fee of 40 USD, we are providing oscommerce upgrade services to work with mysql 5 and php5 issues. This upgradation includes only only the base package of oscommerce and does not include upgrading contributions or custom programming with the existing oscommerce store.

Please use the contact us link to get in touch with us.

Sponsors